Внимание! Старый форум находится здесь. Добавлять новые темы и сообщения на старом форуме нельзя. Старый форум только для просмотра.

АВТО-2 вийшло з ладу через перегрів?

АВТО-2 вийшло з ладу через перегрів?

Сообщение micklecat » 29 июл 2015, 10:35

АВТО-2 я купив приблизно рік назад. Дуже потрібна в автомобілі річ. Трохи "підпилив" його під свої потреби (змінив підтяжку у одного входа, додав заборонений елемент :)). Підключив вхід і4 до сирени сигналізації, припаяв датчик температури, підключився до сервера GPS-Trace Orange. Встановив девайс під пластмасою торпеди над спідометром. Рік працювало все бездоганно, аж поки цим літом не настала спека. Кожного дня, коли машина стояла на сонці, приходили смс-ки про перевищення температури, а порог я встановив 70 градусів. І от тиждень назад ці смс-ки перестали приходити, хоч спека продовжувалася. Більше того, апарат перестав відповідати на послані мною смс. При цьому трекер працював, координати на сервер передавалися справно. Учора вийняв девайс із машини. Зовнішній вигляд вразив: пластмасовий корпус був деформований від нагріву (!!!). Зробив апарату заводські установки натисненням на кнопку. Подзвонив на нього - апарат відповів, я послав DTMF команду *8 - у відповідь прийшли дві смски, а мій номер запам'ятався в апараті. А от якщо послати на апарат смс 123408 або 123402 - відповіді не буде. Якщо послати будь-яку смску з заданням конфігурації (APN, порт, ІР або щось інше) - конфігурація не запишеться. Це можна перевірити, пославши відповідну DTMF команду *8 або *2. В той же час при тривозі по входу і4 апарат шле смс-ку і дзвонить. Може, еепром в процесорі чи датафлеш накрились від перегріву? Адже і процесор, і датафлеш мають температурний діапазон тільки до 85С, а це не зовсім правильно, враховуючи інтенсивність сонця влітку і звичайне місце установки апарата під торпедою. Плату візуально оглянув, видимих тріщин не знайшов. З сім-карточкою все ОК, перевіряв на телефоні, гроші є. На Rx, Tx від проца до сім900 життя присутнє, на виводах датафлеші - теж. Напруга живлення візуально хороша, не просідає. Отака фігня, панове. Якщо одним словом - апарат не програмується і не відповідає на смс. Понесу його сьогодні до вас у ремонт, на Шутова.
micklecat
Любопытный
 
Сообщения: 10
Зарегистрирован: 29 июл 2015, 09:00

Re: АВТО-2 вийшло з ладу через перегрів?

Сообщение boby » 29 июл 2015, 16:35

понесіть - тестування покаже.
але якщо після скидання налаштувань в заводські значення перший вхідний дзвоник все-таки прописується в ЕЕПРОМ як госопдар-1, що перевірено у отриманій смс на відповідний дтмф-запит, то є підозра що у всіх ваших смс-запитах невірно вказується код (можливо десь пробіл). Це всього лише припущення, бо виходячи з вашого опису все працює, крім відповідей на смс-команди.

Не монтуйте прилад в дуже обмеженому просторі, який може бути під прямими сонячними променями, бо там буде локальний перегрів простору!!!
тяжело начинать с нуля, но тяжелее с глубокого минуса
Аватара пользователя
boby
Гуру
 
Сообщения: 2080
Зарегистрирован: 25 дек 2013, 20:16

Re: АВТО-2 вийшло з ладу через перегрів?

Сообщение micklecat » 31 июл 2015, 12:58

Дякую за діагностику, апарат виявився в порядку. Причина була простішою: на моєму телефоні, з якого я посилав на апарат смски, було встановлено кодування тексту смс - юнікод... Блін... :oops: Аж соромно, дорослий дядько, ваш колега, а так лоханувся :D :mrgreen:
micklecat
Любопытный
 
Сообщения: 10
Зарегистрирован: 29 июл 2015, 09:00


Вернуться в GSM автосигнализация АВТО-2

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1

cron